Lighthouse has a new layout. Prefer the old one? Return to the old layout, and switch back any time from the link at the top of each page.

This project is archived and is in readonly mode.

Error Rails 3.0 pre Rack version incompatible

#3613

It appears that Rails 3.0pre installs a version of Rack (i.e. rack-1.0.2.pre.gem) that's incompatible with the installation of actionpack-3.0.pre.gem:


$ sudo rake install
Password:
(in /Users/conradwt/rails.dir/projects/rails)
mkdir -p pkg
  Successfully built RubyGem
  Name: rails
  Version: 3.0.pre
  File: rails-3.0.pre.gem
mv rails-3.0.pre.gem pkg/rails-3.0.pre.gem
(in /Users/conradwt/rails.dir/projects/rails/activesupport)
mkdir -p pkg
  Successfully built RubyGem
  Name: activesupport
  Version: 3.0.pre
  File: activesupport-3.0.pre.gem
mv activesupport-3.0.pre.gem pkg/activesupport-3.0.pre.gem
(in /Users/conradwt/rails.dir/projects/rails/activemodel)
mkdir -p pkg
  Successfully built RubyGem
  Name: activemodel
  Version: 3.0.pre
  File: activemodel-3.0.pre.gem
mv activemodel-3.0.pre.gem pkg/activemodel-3.0.pre.gem
(in /Users/conradwt/rails.dir/projects/rails/actionpack)
mkdir -p pkg
WARNING:  deprecated autorequire specified
  Successfully built RubyGem
  Name: actionpack
  Version: 3.0.pre
  File: actionpack-3.0.pre.gem
mv actionpack-3.0.pre.gem pkg/actionpack-3.0.pre.gem
(in /Users/conradwt/rails.dir/projects/rails/actionmailer)
mkdir -p pkg
WARNING:  deprecated autorequire specified
  Successfully built RubyGem
  Name: actionmailer
  Version: 3.0.pre
  File: actionmailer-3.0.pre.gem
mv actionmailer-3.0.pre.gem pkg/actionmailer-3.0.pre.gem
(in /Users/conradwt/rails.dir/projects/rails/activeresource)
mkdir -p pkg
WARNING:  deprecated autorequire specified
  Successfully built RubyGem
  Name: activeresource
  Version: 3.0.pre
  File: activeresource-3.0.pre.gem
mv activeresource-3.0.pre.gem pkg/activeresource-3.0.pre.gem
(in /Users/conradwt/rails.dir/projects/rails/activerecord)
mkdir -p pkg
WARNING:  deprecated autorequire specified
  Successfully built RubyGem
  Name: activerecord
  Version: 3.0.pre
  File: activerecord-3.0.pre.gem
mv activerecord-3.0.pre.gem pkg/activerecord-3.0.pre.gem
(in /Users/conradwt/rails.dir/projects/rails/railties)
mkdir -p pkg
WARNING:  bin/rails is missing #! line
  Successfully built RubyGem
  Name: railties
  Version: 3.0.pre
  File: railties-3.0.pre.gem
mv railties-3.0.pre.gem pkg/railties-3.0.pre.gem
  Successfully built RubyGem
  Name: arel
  Version: 0.2.pre
  File: arel-0.2.pre.gem
Successfully installed arel-0.2.pre
1 gem installed
(in /Users/conradwt/rails.dir/projects/rails/rack)
gem build rack.gemspec
WARNING:  bin/rackup is missing #! line
  Successfully built RubyGem
  Name: rack
  Version: 1.0.2.pre
  File: rack-1.0.2.pre.gem
Successfully installed rack-1.0.2.pre
1 gem installed
INSTALLING activesupport
Successfully installed activesupport-3.0.pre
1 gem installed
INSTALLING activemodel
Successfully installed activemodel-3.0.pre
1 gem installed
INSTALLING actionpack
ERROR:  Error installing actionpack/pkg/actionpack-3.0.pre.gem:
    actionpack requires rack (~> 1.1.0, runtime)
INSTALLING actionmailer
ERROR:  Error installing actionmailer/pkg/actionmailer-3.0.pre.gem:
    actionmailer requires actionpack (= 3.0.pre, runtime)
INSTALLING activeresource
Successfully installed activeresource-3.0.pre
1 gem installed
INSTALLING activerecord
Successfully installed activerecord-3.0.pre
1 gem installed
ERROR:  Error installing railties/pkg/railties-3.0.pre.gem:
    railties requires actionpack (= 3.0.pre, runtime)
ERROR:  Error installing pkg/rails-3.0.pre.gem:
    rails requires actionpack (= 3.0.pre, runtime)

Reported by Conrad Taylor · December 24th, 2009 @ 08:13 AM

State: resolved
Milestone: none
Assigned to: nobody
Importance: none

Activity

  1. Jeremy Kemper
    Jeremy Kemper
    • State changed from new to resolved

    Fixed. Depends on the 1.1.pre gem, not 1.0.2.pre.

    December 24th, 2009 @ 08:53 AM

  2. Conrad Taylor
    Conrad Taylor

    Jeremy, what should be my course of action to resolve this issue? DHH mentioned #3606 Unable to run working edge app with vendored rails. that ones has to build rack/master for rails/master. Is this still the case?

    December 25th, 2009 @ 03:18 AM

  3. jack dempsey (jackdempsey)
    jack dempsey (jackdempsey)

    Conrad,

    I just cloned down the rack source, did a gem build rack.gemspec, saw that it was referencing RDOX and SPEC files which didn't exist (so I created them), ran the build again, installed the rack 1.1.0-pre gem, and ran my rake install again for rails.

    Looks like things are installing correctly. Now to get rvm stuff fixed up.

    December 27th, 2009 @ 02:23 AM

  4. Conrad Taylor
    Conrad Taylor

    Jack, thanks for the information and I'll proceed as you have. BTW, did you publish you fix back to the rack project?

    December 27th, 2009 @ 09:04 AM