This project is archived and is in readonly mode.

#224 ✓resolved
Pete Deffendol

Ruby 1.8.6 required for Rails 2.1?

Reported by Pete Deffendol | May 19th, 2008 @ 06:44 PM

Apparently Rails now requires Ruby 1.8.6, since the ActiveSupport:TestCase changes were made in January? I'm running the 2.1 release candidate, and get the following error when running our test suite on Ruby 1.8.5:

[snip]/activesupport/lib/active_support/dependencies.rb:491:in `const_missing': uninitialized constant Test::Unit::TestCase::PASSTHROUGH_EXCEPTIONS (NameError)

The referenced constant doesn't exist in my 1.8.5 install. I don't necessarily consider this a Rails bug, but this should be documented somewhere. A few Linux distros still ship 1.8.5 (RHEL5, in my case.)

Comments and changes to this ticket

Create your profile

Help contribute to this project by taking a few moments to create your personal profile. Create your profile »

<h2 style="font-size: 14px">Tickets have moved to Github</h2>

The new ticket tracker is available at <a href=""></a>

People watching this ticket