Lighthouse has a new layout. Prefer the old one? Return to the old layout, and switch back any time from the link at the top of each page.

This project is archived and is in readonly mode.

Rails 2.3.2 CGI doesn't work

#2434

I create a new rails application : rails -D new_app

When I try to run dispatch.cgi from public/, I get this error:

/home/bla/.gem/ruby/1.8/gems/actionpack-2.3.2/lib/action_controller/cgi_process.rb:22:in __send__': You have a nil object when you didn't expect it! (NoMethodError) The error occurred while evaluating nil.env_table

from /home/bla/.gem/ruby/1.8/gems/actionpack-2.3.2/lib/action_controller/cgi_process.rb:22:in `dispatch_cgi'
from /home/bla/.gem/ruby/1.8/gems/actionpack-2.3.2/lib/action_controller/dispatcher.rb:102:in `dispatch_cgi'
from /home/bla/.gem/ruby/1.8/gems/actionpack-2.3.2/lib/action_controller/dispatcher.rb:28:in `dispatch'
from ./dispatch.cgi:10

Is CGI dropped? Will be dropped completely in the near future? I was using CGI for small applications in shared hosting that supported CGI but don't support mod_rails.

Any solutions, work-arounds?

Reported by Jon Vlachoyianis · April 6th, 2009 @ 10:07 PM

State: stale
Milestone: 3.x
Assigned to: nobody
Importance: none

Activity

  1. Max Lapshin
    Max Lapshin

    As far as I know, CGI is really deprecated

    April 20th, 2009 @ 09:00 PM

  2. Ngoc Dao
    Ngoc Dao

    Run rake rails:update:generate_dispatchers to generate dispatcher files in RAILS_ROOT/public.

    July 11th, 2009 @ 01:14 PM

  3. comopasta
    comopasta

    "Run rake rails:update:generate_dispatchers to generate dispatcher files in RAILS_ROOT/public."

    I have the same problem also.
    I used rake rails:update:generate_dispatchers but the generated ones were exactly the same as those that I had before...
    So didn't help.

    I'm running on a shared hosting as well so I don't have much freedom there.

    Regards

    July 15th, 2009 @ 06:36 AM

  4. techarch
    techarch

    I am having the same issue after generating the dispatchers. Has anyone figure out how to resolve this?

    July 15th, 2009 @ 08:03 PM

  5. Thorbjørn Hermansen
    Thorbjørn Hermansen

    I have this one too. Both on my development computer and on my web hotel. Reverting back to Rails 2.2.2 and it's working, but not with 2.3.x.

    August 8th, 2009 @ 09:48 PM

  6. Jeremy Kemper
    Jeremy Kemper
    • Milestone changed from 2.x to 3.x

    May 4th, 2010 @ 06:48 PM

  7. Rohit Arondekar
    Rohit Arondekar
    • State changed from new to stale
    • Importance changed from to

    Marking ticket as stale. If this is still an issue please leave a comment with suggested changes, creating a patch with tests, rebasing an existing patch or just confirming the issue on a latest release or master/branches.

    October 14th, 2010 @ 02:48 PM