This project is archived and is in readonly mode.
The rake tasks db:create and db:drop throws an error when the database.yml file is configured in a non default location.
-
Santiago Pastorino
- State changed from new to open
- Tag changed from databases.rake, rake_dev to databasesrake, rake_dev
This issue has been automatically marked as stale because it has not been commented on for at least three months.
The resources of the Rails core team are limited, and so we are asking for your help. If you can still reproduce this error on the 3-0-stable branch or on master, please reply with all of the information you have about it and add "[state:open]" to your comment. This will reopen the ticket for review. Likewise, if you feel that this is a very important feature for Rails to include, please reply with your explanation so we can consider it.
Thank you for all your contributions, and we hope you will understand this step to focus our efforts where they are most helpful.
-
Santiago Pastorino
- State changed from open to stale
-
Kandada Boggu
- Assigned user set to Santiago Pastorino
I can still reproduce this error on Rails 2.3.9. Please run
rake db:createon the attached project to reproduce the error. -
Santiago Pastorino
- State changed from stale to open
- Milestone set to 2.3.10
- Assigned user cleared.
- Importance changed from to Low
-
Vijay Dev
- Tag changed from databasesrake, rake_dev to configuration, database.yml, databasesrake, rake_dev
- Assigned user set to Santiago Pastorino
The issue seems to be solved when I change the
load_configtask to depend on theenvironmenttask instead ofrails_envand remove the assignment toActiveRecord::Base.configurations. Is this a right approach? How can I test this?I would like to know the reasoning behind allowing the path to database.yml to be configurable.
Also, there is at least one more issue concerning the database.yml path #1710
-
Kandada Boggu
We have built a product using Rails framework. Most of our customers/field engineers have no ruby/rails background. When the product is installed, code resides in a directory with read permissions and log/config files reside in a directory with read/write permission. The config directory contain ONLY the files that an administrator can change, i.e.
database.ymlandapp_config.yml. This done in order to avoid any mishaps in production systems.This is a common pattern for a corporate deployment. When we deploy on EC2, an EBS volume stores the configuration and log files and AMI has the project source.
-
Santiago Pastorino
- Assigned user cleared.
