This project is archived and is in readonly mode.

#4837 ✓resolved

Rails master version check is broken.

Reported by stefanpenner | June 11th, 2010 @ 10:38 PM

ruby -v
ruby 1.8.7 (2009-12-24 patchlevel 248) [i686-darwin10.3.0], MBARI 0x6770, Ruby Enterprise Edition 2010.01

rails s
Rails 3 requires Ruby 1.8.7 or 1.9.2.
You're running 1.8.7 (2009-12-24); please upgrade to continue.

Solution 1:
explicit version conditions

   unless %W{1.8.7 1.9.2}.include?(RUBY_VERSION)
     abort ...


Solution 2:
some sort of range conditional but im not sure the criteria.

   if ruby_release < '1.8.7' || (ruby_release > '1.8.8' && ruby_release < '1.9.2')
      abort ...


Comments and changes to this ticket

Create your profile

Help contribute to this project by taking a few moments to create your personal profile. Create your profile »

<h2 style="font-size: 14px">Tickets have moved to Github</h2>

The new ticket tracker is available at <a href=""></a>