This project is archived and is in readonly mode.
Rails3 RC - Schema.rb file does not contain all indexes created with migration in postgresql (postgres)
-
codemanki
Robert, yes, this is because there is a limit of 64 chars per index name - database_limits.rb:21
And here is a exception which must be raise, but i think in migrations it doesn't - schema_statements.rb:341
-
codemanki
This ticket can be closed, i suppose. I tested these migrations and got
add_index': Index name 'index_business_object_type_functions_on_function_id_and_business_object_type_id' on table 'business_object_type_functions' is too long; the limit is 64 characters (ArgumentError) </code>
/Users/codemanki/projects/misc/rails/activerecord/lib/active_record/connection_adapters/abstract/schema_statements.rb:341:in -
David Trasbo
- State changed from new to invalid
- Importance changed from to Low
-
Robert Pankowecki
Which rails version raises the exception during migration. What database did you use during the test ?