Lighthouse has a new layout. Prefer the old one? Return to the old layout, and switch back any time from the link at the top of each page.

This project is archived and is in readonly mode.

Routing errors serving static files with Mongrel

#2180

Mongrel produces a routing error when serving static files without using a complete url.

i.e. GET /folder doesn't render public/folder/index.html but instead raises a routing error.

An empty route does serve public/index.html, as one would expect, but no XHTML files in subdirectories are ever served.

This behaviour did not exist in Rails 2.2.2.

Reported by James Conroy-Finn · March 9th, 2009 @ 03:53 PM

State: resolved
Milestone: none
Assigned to: josh josh
Importance: none

Activity

  1. Tor Erik
    Tor Erik
    • Tag changed from 2.3, mongrel, routing to 2.3, 2.3-rc2, mongrel, routing

    This looks like a regression.

    Before 2.3:

    /               =>  public/index.html
    /foo/bar/  =>  public/foo/bar/index.html
    
    

    After 2.3:

    /              =>  public/index.html
    /foo/bar/ =>  404
    
    

    March 9th, 2009 @ 10:28 PM

  2. josh
    josh
    • Assigned user set to josh
    • Milestone cleared.

    Does this happen on script/server, mongrel_rails, or both?

    March 10th, 2009 @ 12:32 AM

  3. Repository
    Repository
    • State changed from new to resolved

    (from [0c9bbf8c9dca46fbd7916640c417d13bf8b5af30]) Fix serving index files with rack static file server [#2180 state:resolved] http://github.com/rails/rails/co...

    March 10th, 2009 @ 04:31 AM

  4. James Conroy-Finn
    James Conroy-Finn

    It was with script/server. Thanks for the fix Josh.

    March 10th, 2009 @ 09:34 AM