Lighthouse has a new layout. Prefer the old one? Return to the old layout, and switch back any time from the link at the top of each page.

This project is archived and is in readonly mode.

Complete move to Rack

#1440

Finish the Rack adapters for Rails including dealing with the issue of Rails' own FCGI adapter being more battle tested than the one in Rack.

Reported by DHH · November 22nd, 2008 @ 05:32 PM

State: resolved
Milestone: none
Assigned to: josh josh
Importance: none

Activity

  1. josh
    josh
    • State changed from new to open

    Just switched script/server over to Rack. I just need to do the same for the FCGI adapter.

    http://github.com/rails/rails/co...

    November 22nd, 2008 @ 08:50 PM

  2. josh
    josh
    • State changed from open to resolved

    December 1st, 2008 @ 06:32 PM

  3. Jan De Poorter
    Jan De Poorter

    The change in http://github.com/rails/rails/co... breaks my request dispatching.

    [05/Dec/2008:11:02:20 :: 26836] Dispatcher failed to catch: undefined method env' for #<FCGI::CGI:0xb6dfb0f4> (NoMethodError) /usr/lib/ruby/gems/1.8/gems/rack-0.4.0/lib/rack/handler/fastcgi.rb:32:inserve' /home/sock/apps/sock/releases/20081205100135/vendor/rails/railties/lib/fcgi_handler.rb:101:in process_request' /home/sock/apps/sock/releases/20081205100135/vendor/rails/railties/lib/fcgi_handler.rb:151:inwith_signal_handler' /home/sock/apps/sock/releases/20081205100135/vendor/rails/railties/lib/fcgi_handler.rb:99:in process_request' /home/sock/apps/sock/releases/20081205100135/vendor/rails/railties/lib/fcgi_handler.rb:76:inprocess_each_request' /usr/lib/ruby/gems/1.8/gems/fcgi-0.8.7/lib/fcgi.rb:612:in each_cgi' /usr/lib/ruby/gems/1.8/gems/fcgi-0.8.7/lib/fcgi.rb:609:ineach' /usr/lib/ruby/gems/1.8/gems/fcgi-0.8.7/lib/fcgi.rb:609:in each_cgi' /home/sock/apps/sock/releases/20081205100135/vendor/rails/railties/lib/fcgi_handler.rb:75:inprocess_each_request' /home/sock/apps/sock/releases/20081205100135/vendor/rails/railties/lib/fcgi_handler.rb:74:in catch' /home/sock/apps/sock/releases/20081205100135/vendor/rails/railties/lib/fcgi_handler.rb:74:inprocess_each_request' /home/sock/apps/sock/releases/20081205100135/vendor/rails/railties/lib/fcgi_handler.rb:49:in process!' /home/sock/apps/sock/releases/20081205100135/vendor/rails/railties/lib/fcgi_handler.rb:23:inprocess!' /home/sock/apps/sock/current/public/dispatch.fcgi:24 unhandled dispatch error

    December 5th, 2008 @ 10:25 AM

  4. Jan De Poorter
    Jan De Poorter

    It seems that the Rack::FastCGI adapter expects a FCGI object, while the fcgi_handler gives it a FCGI::CGI object

    December 5th, 2008 @ 11:44 AM

  5. josh
    josh

    @Jan De Poorter Thanks for the alert. This seems critical. Can you please start a new ticket for the probem. I'd like to know more details about what server you are running to feed FCGI, etc.

    December 5th, 2008 @ 03:37 PM

  6. Alexander Semyonov