This project is archived and is in readonly mode.

#2327 ✓resolved
Thomas E. Glasgow

Rewrote ActionController.filter_chain for better readability

Reported by Thomas E. Glasgow | March 24th, 2009 @ 03:12 PM | in 2.x

While on my journey to explore the Rails source code and have a better understanding of how things work under the hood, I ran into the filter_chain method. The code was too verbose and was rewritten to a nicer Ruby idiom using the || operator.

All original tests pass.

Best regards,

Comments and changes to this ticket

Create your profile

Help contribute to this project by taking a few moments to create your personal profile. Create your profile »

<h2 style="font-size: 14px">Tickets have moved to Github</h2>

The new ticket tracker is available at <a href=""></a>

People watching this ticket


Referenced by