This project is archived and is in readonly mode.

#6558 open
Diego Carrion

Alias for escape_javascript

Reported by Diego Carrion | March 10th, 2011 @ 11:20 PM | in 3.1

Hi, escape_javascript is used a lot in views that render javascript and can difficult the readability of the code. The attached patch ads an alias called js, so the code stays cleaner. Its similar to the h alias for html_escape.

Comments and changes to this ticket

  • Santiago Pastorino

    Santiago Pastorino March 11th, 2011 @ 01:03 AM

    • State changed from “new” to “open”
    • Milestone set to 3.1
    • Importance changed from “” to “Low”

    Hey Diego, I don't think that's a good idea. We already have a j helper to escape json.
    The best is to deprecate the helper for 3-0-stable and remove it from master.

Create your profile

Help contribute to this project by taking a few moments to create your personal profile. Create your profile »

<h2 style="font-size: 14px">Tickets have moved to Github</h2>

The new ticket tracker is available at <a href=""></a>