This project is archived and is in readonly mode.

#2636 ✓resolved
Claudio Poli

Illformed requirement on edge with certain versions of ruby

Reported by Claudio Poli | May 11th, 2009 @ 10:19 PM | in 2.x

hi everyone, I'm using latest edge snapshot.

upon script/server:

/System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/1.8/rubygems/requirement.rb:144:in `parse': Illformed requirement ["~> 1.1.pre"] (ArgumentError)
	from /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/1.8/rubygems/requirement.rb:70:in `initialize'
	from /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/1.8/rubygems/requirement.rb:69:in `map'
	from /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/1.8/rubygems/requirement.rb:69:in `initialize'
	from /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/1.8/rubygems/requirement.rb:42:in `new'
	from /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/1.8/rubygems/requirement.rb:42:in `create'
	from /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/1.8/rubygems/dependency.rb:29:in `initialize'
	from /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/1.8/rubygems.rb:307:in `new'
	from /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/1.8/rubygems.rb:307:in `activate'
	 ... 8 levels...
	from /Users/kain/Sites/careme/vendor/rails/railties/lib/commands/server.rb:1
	from /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/1.8/rubygems/custom_require.rb:27:in `gem_original_require'
	from /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/1.8/rubygems/custom_require.rb:27:in `require'
	from script/server:3

this is with leopard vanilla ruby. I tried also with a not so recent version (20090113) of Ruby Enterprise Edition and got the same error; I updated REE (20090421) and the problem disappeared.

Comments and changes to this ticket

  • Claudio Poli

    Claudio Poli May 11th, 2009 @ 10:32 PM

    upon further investigation seems like it's the rubygems version, not the ruby version.

    rubygems version:

    1.3.3 - no error 1.3.2 - no error 1.3.1 - error 1.0.1 - error (vanilla leopard)

    if this is an intended change, feel free to close.

  • CancelProfileIsBroken

    CancelProfileIsBroken May 12th, 2009 @ 12:17 AM

    • State changed from “new” to “resolved”

    Yes, by design. Edge depends on rubygems 1.3.2 or higher.

Create your profile

Help contribute to this project by taking a few moments to create your personal profile. Create your profile »

<h2 style="font-size: 14px">Tickets have moved to Github</h2>

The new ticket tracker is available at <a href=""></a>

People watching this ticket