This project is archived and is in readonly mode.

#3558 ✓resolved
Matt Jones

Actionpack 2.3.5 gemspec and Rack requirement don't match

Reported by Matt Jones | December 10th, 2009 @ 06:02 PM | in 2.3.6

This commit:

bumped the required version of Rack to 1.0.1, but the gemspec only specifies 1.0.0. This can cause problems when installing on a machine with 2.3.2 previously installed, as the Rack 1.0.0 gem is present and satisfies the specified dependency (but blows up when actually starting the app).

Attached single-character patch fixes the actionpack Rakefile to generate a correct specification.

Comments and changes to this ticket

Create your profile

Help contribute to this project by taking a few moments to create your personal profile. Create your profile »

<h2 style="font-size: 14px">Tickets have moved to Github</h2>

The new ticket tracker is available at <a href=""></a>

Referenced by