This project is archived and is in readonly mode.

#3685 ✓ invalid
Daniel Azuma

ActionPack 2.3.5 gem declares incompatibility with rack 1.1.0

Reported by Daniel Azuma | January 11th, 2010 @ 11:39 PM | in 3.0.2

The issue is that actionpack-2.3.5 declares a gem dependency of ("rack", "~> 1.0.0"). This syntax indicates that the recently-released rack 1.1.0 is not compatible. Hence, rails attempts to load an earlier version of rack even if 1.1.0 is installed.

This can cause an application to fail to start in the following circumstance. With the following gems installed:

rails 2.3.5 (and dependencies)
rack 1.0.1 (a rails dependency)
rack 1.1.0
thin 1.2.5

Attempting to start rails on the thin webserver using "thin start --adapter rails" causes rails to erroneously report "Missing the Rails 2.3.5 gem". In fact, what has actually taken place is that thin has already loaded rack 1.1.0 (the latest version of rack). Rails then comes in and attempts to load an earlier version of rack such as 1.0.1, which causes a Gem::LoadError, leading boot.rb to report the error.

As a workaround for sites that are deployed using thin, we can hold off on installing rack 1.1.0. However, I believe actionpack's dependency declaration of ("rack", "~> 1.0.0") is in error.

Comments and changes to this ticket

Create your profile

Help contribute to this project by taking a few moments to create your personal profile. Create your profile »

Tickets have moved to Github

The new ticket tracker is available at https://github.com/rails/rails/issues

Shared Ticket Bins

Attachments

Referenced by

Pages